The full rollback for Visa was successfully completed in close coordination with the Visa team on February 10th at 9:30 PM PT, The implementation was executed smoothly, and no abnormality was observed.
For Pulse, we are actively coordinating next steps with their team. For an aligned maintenance window for fix implementation to ensure proper timing and minimize any potential downtime.
We continue to closely monitor the environment and confirm that no duplicate transactions have been observed since Friday, February 6th at 6:00 PM PT / 2:00 AM UTC. At this time, we do not anticipate additional impact to either the Visa or Pulse card networks. We will provide further updates as additional information becomes available and appreciate your continued patience.
Posted Feb 11, 2026 - 09:34 PST
Update
A non-impact partial fix for the issue was applied to Pulse on February 9th at 06:30 PM PT. Our engineering team is currently working with priority on finalizing the full-scale fix, and we will provide an update as soon as it is ready for deployment.
We continue to confirm that no duplicate transactions have been observed since Friday, February 6th at 6:00 PM PT/2:00 AM UTC. We do not expect any further impact to either the Visa or Pulse card networks.
We deeply appreciate your patience and remain fully committed to providing explicit communication throughout the resolution process.
Posted Feb 10, 2026 - 12:32 PST
Update
Engineers are scheduling the fix for Visa and Pulse. No duplicate transactions have been observed since Friday, February 6th at 6:00 PM PT/2:00 AM UTC. We do not expect any further impact to either card network.
Posted Feb 09, 2026 - 13:41 PST
Update
Our team has identified the cause of duplicate transaction postings as an issue introduced in a recent release. We've successfully completed a rollback for Mastercard. As a precautionary measure, we're scheduling the Visa and Pulse fixes for Monday, February 9th to avoid any potential impact during the weekend.
All duplicate transactions will be automatically reversed within 48 hours, and no action is required from affected customers.
We will provide our next update on Monday unless new information becomes available sooner.
Posted Feb 06, 2026 - 18:05 PST
Identified
We've identified the cause of the duplicate transaction issue and are implementing a fix.
Posted Feb 06, 2026 - 16:00 PST
Update
Our team is conducting a thorough investigation to determine the root cause while working on a resolution. We will provide updates as soon as new information becomes available.
Posted Feb 06, 2026 - 15:16 PST
Investigating
Starting January 22nd, some customers may notice duplicate transaction postings. Our engineering team is actively working to resolve this issue. Affected customers do not need to take any action.