Marqeta engineering teams have resolved the service disruption affecting the Marqeta Dashboard, Diva, and 3DS at 11:00 PDT. The root cause was an infrastructure configuration change that inadvertently restricted network connectivity for our production database environment, which has since been remediated. We have concluded performance monitoring to ensure long-term stability, and all services are now operational. We appreciate your patience as we worked to resolve this incident.
Posted Jul 31, 2026 - 11:38 PDT
Identified
Our engineering team has identified the root cause of the service disruption affecting the Marqeta Dashboard, Diva, and 3DS. The issue originated from an infrastructure configuration that inadvertently restricted network connectivity for our production database environment. We are currently implementing a fix to restore the service . We apologize for the impact this has caused and will provide further updates as our restoration efforts conclude.
Posted Jul 31, 2026 - 11:04 PDT
Update
Marqeta engineering is actively investigating a service disruption affecting database connectivity across multiple services, including the Marqeta Dashboard, Diva, and 3DS. Our teams are currently investigating underlying infrastructure and network-level issues. We have escalated the matter to service provider and are coordinating across engineering teams to restore service. Further updates will be provided as our investigation progresses.
Posted Jul 31, 2026 - 10:47 PDT
Investigating
Marqeta engineering team is investigating a service disruption affecting the Marqeta Dashboard and Diva. Our teams are actively working to mitigate the issue and restore full service.A follow-up notification with more detail will be sent within 30 minutes.
Posted Jul 31, 2026 - 10:19 PDT
This incident affected: Reporting & Analytics and 3DS.