Marqeta Dashboard Outage and Delayed Clearing

Incident Report for Marqeta

Resolved

Engineers have remediated the delayed foreign-currency transaction clearing files. All affected services are now fully restored.
Posted Jun 22, 2026 - 01:57 PDT

Update

On Sunday, June 21, 2026, Marqeta engineers detected a renewed issue affecting foreign-currency transaction clearing on Mastercard and Visa starting at approximately 23:39 PT (06:39 UTC). Our team is continuing to remediate the clearing files. A follow-up notification will be sent when clearing has been remediated, or upon any notable change in condition.
Posted Jun 22, 2026 - 00:46 PDT

Identified

On Sunday, June 21, 2026, Marqeta engineers detected a renewed issue affecting foreign-currency transaction clearing on Mastercard and Visa starting at approximately 23:39 PT (06:39 UTC). Our team is continuing to actively investigate the root cause and remediate the clearing file process.

A follow-up notification with more detail will be sent within 30 minutes.

We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jun 22, 2026 - 00:17 PDT

Update

On Sunday, June 21, 2026, Marqeta engineers detected a renewed issue affecting foreign-currency transaction clearing on Mastercard and Visa starting at approximately 23:39 PT (06:39 UTC). Our team is actively investigating the root cause and assessing the full scope of impact.

A follow-up notification with more detail will be sent within 30 minutes.

We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jun 21, 2026 - 23:46 PDT

Monitoring

On Sunday, June 21, 2026, Marqeta engineers detected an issue affecting the Marqeta Dashboard web portal and a clearing file delivery delay starting at approximately 17:24 PT (00:24 UTC). Marqeta Dashboard has recovered, and clearing file delivery is being monitored to ensure continuity has been restored. We will update this space again if there are any notable changes.
Posted Jun 21, 2026 - 18:42 PDT

Update

On Sunday, June 21, 2026, Marqeta engineers detected an issue affecting the Marqeta Dashboard web portal and a clearing file delivery delay starting at approximately 17:24 PT (00:24 UTC). Marqeta Dashboard has recovered, and engineers are continuing to investigate the impact to clearing.

A follow-up notification with more detail will be sent within 30 minutes.

We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jun 21, 2026 - 18:16 PDT

Update

On Sunday, June 21, 2026, Marqeta engineers detected an issue affecting the Marqeta Dashboard web portal starting at approximately 17:24 PT (00:24 UTC). There is also a one hour delay in clearing files that will affect file delivery timing. Our team is continuing to actively investigate the root cause and assessing the full scope of impact.

A follow-up notification with more detail will be sent within 30 minutes.

We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jun 21, 2026 - 17:57 PDT

Investigating

On Sunday, June 21, 2026, Marqeta engineers detected an issue affecting the Marqeta Dashboard web portal starting at approximately 17:24 PT (00:24 UTC). Our team is actively investigating the root cause and assessing the full scope of impact.

A follow-up notification with more detail will be sent within 30 minutes.

We appreciate your patience as we work to resolve this as quickly as possible.
Posted Jun 21, 2026 - 17:32 PDT
This incident affected: Payment Processing and Reporting & Analytics.