3DS challenges are impaired

Incident Report for Marqeta

Resolved

We have verified that this is resolved.
Posted Jun 05, 2025 - 19:40 PDT

Monitoring

A fix has been implemented and we have validated successful transactions. We will continue to monitor.
Posted Jun 05, 2025 - 18:47 PDT

Identified

Marqeta has identified an issue that is impacting the challenge flow for our 3DS service. The root cause has been identified and a fix is being implemented.
Posted Jun 05, 2025 - 18:41 PDT
This incident affected: 3DS.