STIPS on Master Card network

Incident Report for Marqeta

Resolved

We are confirming that the Mastercard network disturbance, which caused two isolated periods of elevated (STIP) earlier today around 11:14 AM and 12:45 PM Pacific Time, is now fully resolved and the service is operating normally. Our engineering team monitored the service to ensure stability with no abnormality observed.
Posted Mar 12, 2026 - 17:50 PDT

Monitoring

Marqeta Engineering team observed network disturbance resulting in STIPS on the Mastercard network, We observed two distinct periods of impact, starting around 11:14 AM and 12:45 PM Pacific Time , the status is currently stable and our team is actively engaged with MasterCard to understand the root cause.
We are continuously monitoring the network to ensure stability.
Posted Mar 12, 2026 - 13:29 PDT
This incident affected: Payment Processing.