Degraded traffic on Mastercard 3DS

Incident Report for Marqeta

Resolved

Marqeta engineers have confirmed the errors have subsided. Although we continue to await an RCA from Mastercard, evidence indicates they deployed a broken certificate bundle and have been progressively redeploying them them. We will continue to monitor for any additional lagging effects.
Posted Jul 17, 2026 - 10:30 PDT

Monitoring

On Wednesday, July 15, 2026, Marqeta engineers detected a new issue affecting Mastercard 3D Secure (3DS) authentication requests, starting at approximately 13:04 PT (20:04 UTC). Marqeta engineers have detected a decrease in the rate of errors. We are continuing to wait for guidance or confirmation from Mastercard that the issue has been resolved. A follow-up notification with more detail will be provided once Mastercard completes their analysis.
Posted Jul 16, 2026 - 11:29 PDT

Identified

On Wednesday, July 15, 2026, Marqeta engineers detected a new issue affecting Mastercard 3D Secure (3DS) authentication requests, starting at approximately 13:04 PT (20:04 UTC). Mastercard is continuing to work to determine the root cause and correct it. A follow-up notification with more detail will be provided once Mastercard completes their analysis.
Posted Jul 16, 2026 - 07:28 PDT

Update

On Wednesday, July 15, 2026, Marqeta engineers detected a new issue affecting Mastercard 3D Secure (3DS) authentication requests, starting at approximately 13:04 PT (20:04 UTC). Our team is actively investigating with Mastercard to determine the root cause and assess the full scope of impact. A follow-up notification with more detail will be provided once Mastercard completes their analysis.
Posted Jul 15, 2026 - 13:52 PDT

Investigating

On Wednesday, July 15, 2026, Marqeta engineers detected a new issue affecting Mastercard 3D Secure (3DS) authentication requests, starting at approximately 13:04 PT (20:04 UTC). Our team is actively investigating the root cause and assessing the full scope of impact. A follow-up notification with more detail will be sent within 30 minutes.
Posted Jul 15, 2026 - 13:18 PDT
This incident affected: 3DS.