Intermittent STIPs across multiple networks

Incident Report for Marqeta

Monitoring

Following our investigation with the database vendor, a tactical fix was successfully applied at 16:26 PST. Since the implementation of this fix, we have observed a significant improvement in database connection stability and a return to normal service levels.
Our engineering team is continuously monitoring the environment to verify the long-term effectiveness of the resolution and ensure overall system stability.
We will provide a final update once we have confirmed the issue is fully resolved and appreciate your continued patience.
Posted Apr 02, 2026 - 20:10 PDT

Identified

We have observed a database connectivity issue that intermittently impacted Marqeta services on April 1st between 16:04 and 17:56 PST. During this window, some customers may have experienced an elevated amount of STIPs as well as partial disruptions to tokenization and API traffic.

Our engineering team has traced the instability to an intermittent database connection failure and has escalated the matter to our third-party vendor for support. We are currently engaged in an active troubleshooting with the vendor's support to isolate the root cause and prevent recurrence by applying a tactical solution.

We apologize for any inconvenience this incident may caused, and will periodically provide updates once available.
Posted Apr 02, 2026 - 13:31 PDT
This incident affects: Core API, Payment Processing, and Digital Wallets & Tokenization.