There have been no reoccurrences detected. We will continue to follow up with Visa to ensure an RCA is conducted
Posted Aug 14, 2026 - 06:18 PDT
Monitoring
Visa has identified a data centre that was overloading and creating a "noisy neighbour", impacting Marqeta's Click to Pay service. After they isolated that system, we observed the service returning to normal. We will continue to monitor for any reoccurrences, and we will continue to follow up with Visa to ensure an RCA is conducted.
Posted Aug 13, 2026 - 14:28 PDT
Update
We are continuing to actively engage with Visa to resolve the intermittent service disruptions affecting Visa's "Click to Pay" API endpoints. They have confirmed that they have a team working on root cause analysis and are also working on a plan to expedite the resolution. We apologize for the impact this has caused and will provide further updates as we receive more information from our partner.
Posted Aug 13, 2026 - 13:59 PDT
Identified
We are actively in engagement with Visa to resolve the intermittent service disruptions affecting Visa's "Click to Pay" API endpoints. Our team has raised high priority case with Visa and is working directly with their support to identify the root cause and expedite the resolution. We apologize for the impact this has caused and will provide further updates as we receive more information from our partner.
Posted Aug 13, 2026 - 12:15 PDT
Investigating
We are currently investigating an Intermittent service disruption affecting the Visa "Click to Pay" service, which began on August 13th 09:45 PST. Our engineering team is actively collaborating with Visa to identify the root cause and restore full functionality as quickly as possible. We are monitoring the situation closely and will provide further updates as more information becomes available from Visa's side.
Posted Aug 13, 2026 - 11:07 PDT
This incident affected: Digital Wallets & Tokenization.