Data Replication Lag in Snowflake

Incident Report for Marqeta

Resolved

Engineers report the replication lag is over and the data should now be caught up.
Posted Oct 15, 2025 - 17:05 PDT

Monitoring

Data pipeline issues have been resolved. Marqeta engineers have allocated extra resources to ensure data is caught back up quickly.
Posted Oct 15, 2025 - 10:58 PDT

Update

We are continuing to experience data synchronization delays starting around 02:30 AM PST. Some data pipelines to Snowflake are experiencing intermittent issues. This may impact downstream reporting or analysis that requires intraday data. Our team is actively investigating and working on a resolution. Updates will follow as we learn more.
Posted Oct 15, 2025 - 09:35 PDT

Investigating

The Confluent sink connector is experiencing degraded performance. Starting from 02:30 AM PST some customers may see a lag between MySQL tables and Snowflake. This will impact downstream reporting or analysis that required intraday data. Engineers are aware of the issue and are working on a solution.
Posted Oct 15, 2025 - 07:43 PDT
This incident affected: Reporting & Analytics.