API Endpoint intermittent Connectivity Issues

Incident Report for Marqeta

Resolved

On July 21, 2026, a subset of customers experienced intermittent failures when accessing Marqeta API endpoints. The issue was caused by an insufficient number of service instances in a specific availability zone, which led to resource constraints and connection limit exhaustion under load. Our engineering team resolved the issue by scaling up instance capacity and significantly increasing connection limits to address the underlying scaling constraints. All affected services have returned to normal operation and we have confirmed stable performance across the platform after concluding a monitoring period. We sincerely apologize for any disruption this caused and thank you for your patience.
Posted Jul 21, 2026 - 16:07 PDT

Monitoring

On Tuesday, July 21, 2026, Marqeta engineering team investigated an issue affecting a subset of our customers experiencing intermittent failures when accessing Marqeta API endpoints. Marqeta engineering team has completed at 06:40 PT a configuration change as part of our ongoing remediation efforts. No further intermittent SSL handshake connection failures are currently observed .We are continuing to closely monitor our systems and analyze metrics to determine the root cause and ensure full service stability. We will share a resolving update once long term stability is confirmed.
Posted Jul 21, 2026 - 07:00 PDT

Identified

Marqeta engineering team is currently investigating an issue affecting a subset of our customers experiencing intermittent failures when accessing Marqeta API endpoints. Our engineering team has identified the issue and is actively working to remediate it .We will provide a further update within the next 30 minutes as our teams continue to work toward full resolution. We sincerely apologize for any disruption this may be causing to your operations and appreciate your patience as we work urgently to restore full service.
Posted Jul 21, 2026 - 06:31 PDT
This incident affected: Core API.