Missing Data due to Replication Lag

Incident Report for Marqeta

Resolved

Marqeta engineers report the missing data should now be remediated for all customers.
Posted Oct 17, 2025 - 14:03 PDT

Update

Marqeta engineers are continuing to identify and remediate missing data throughout today.
Posted Oct 17, 2025 - 06:00 PDT

Update

Marqeta engineers are continuing to identify and remediate missing data.
Posted Oct 16, 2025 - 13:54 PDT

Identified

On October 15th data synchronization delays starting around 02:30 AM PST. The lag was corrected and the data caught up by approximately 16:30 PST. We have received reports from some customers of missing data. Marqeta engineers are actively remediating this data.
Posted Oct 16, 2025 - 12:16 PDT
This incident affected: Reporting & Analytics.