Reporting API Experiencing Degraded Performance

Incident Report for Marqeta

Resolved

Reporting should now be caught up after Snowflake's outage.
Posted Mar 21, 2025 - 05:39 PDT

Monitoring

Snowflake reports that the issue has been resolved. Recovery from the delayed reporting is ongoing.
Posted Mar 19, 2025 - 14:54 PDT

Identified

Snowflake has identified the issue and they are working on a solution. Follow their progress on their status page: https://status.snowflake.com/incidents/9mwvw50z4wnm
Posted Mar 19, 2025 - 11:18 PDT

Investigating

Some users of Reports and/or the Reporting API may experience delayed performance or inability to pull/update reports. We are working with Snowflake to determine the cause of this difficulty.
Posted Mar 19, 2025 - 10:14 PDT
This incident affected: Reporting & Analytics.