MasterCard has identified the root cause of the issue and stabilized their systems. Performance across all impacted endpoints—including Token Lifecycle Management, Click to Pay enrolment, API-based dispute submissions, and Card Activations—has fully recovered, and Marqeta customers should no longer be experiencing any impact.
Posted Sep 03, 2026 - 14:57 PDT
Monitoring
Marqeta engineers are observing consistent improvements across all impacted Mastercard integration services, with error rates and latency returning toward normal levels. Our engineering team continues to closely monitor system health and performance metrics in coordination with Mastercard to ensure sustained stability before fully resolving the incident. Additional updates will be provided as soon as new information is available.
Posted Sep 03, 2026 - 13:15 PDT
Update
We continue to work in close collaboration with Mastercard’s incident response teams, who have confirmed that dedicated technical teams are actively working to address the platform-wide infrastructure issues on their side affecting Token Lifecycle Management, Click to Pay enrolment, API-based dispute submissions, and new Card Activations. We are closely tracking all system health metrics and will provide further updates as soon as additional information becomes available from our partner.
Posted Sep 03, 2026 - 12:41 PDT
Update
Our Monitoring into the service disruption impacting MasterCard integration services continues. We are working in close collaboration with MasterCard’s incident response teams, who have confirmed that an active war room is ongoing to address the platform-wide infrastructure issues from their side affecting Token Lifecycle Management, Click to Pay enrolment, API-based dispute submissions, and new Card Activations. We are monitoring all system health metrics closely and remain committed to restoring full service performance as quickly as possible. We will continue to provide regular updates as we receive more information from our partner.
Posted Sep 03, 2026 - 11:53 PDT
Update
We are continuing to work closely with MasterCard to resolve a service disruption impacting several integration services, which began around 06:30 PDT on September 3, 2026. This issue is resulting in latency and timeout errors for Token Lifecycle Management, Click to Pay enrolment, API-based dispute submissions, and new Card Activations. Our engineering team remains in constant coordination with MasterCard’s incident response team, who have acknowledged the platform-wide infrastructure issue and are prioritizing its resolution. We are closely monitoring the situation to ensure full service restoration and will share additional updates as soon as more information is available from our partner.
Posted Sep 03, 2026 - 11:22 PDT
Update
Marqeta is actively investigating the service disruption impacting MasterCard integration services that began at approximately 06:30 PT on September 3, 2026, which is causing increased latency and timeout errors for token lifecycle management, Click to Pay enrolment, and API-based disputes, claims submissions and Card activation. Our engineering team is continuing to actively monitor the situation and coordinating directly with MasterCard, who has acknowledged a platform-wide issue and giving the utmost priority to resolve the underlying infrastructure problems. We will provide further updates as more information becomes available from our partner.
Posted Sep 03, 2026 - 11:13 PDT
Update
Marqeta is actively investigating the service disruption impacting MasterCard integration services that began at approximately 06:30 PT on September 3, 2026, which is causing increased latency and timeout errors for token lifecycle management, Click to Pay enrolment, and API-based disputes, claims submissions and Card activation. Our engineering team is actively monitoring the situation and coordinating directly with MasterCard, who has acknowledged a platform-wide issue and giving the utmost priority to resolve the underlying infrastructure problems. We will provide further updates as more information becomes available from our partner.
Posted Sep 03, 2026 - 10:33 PDT
Identified
Our engineering team is actively monitoring the situation and coordinating directly with Mastercard, who has acknowledged a service disruption from their side which is causing intermittent degradation and increased latency for token lifecycle management and Click to Pay enrolment requests and is working toward a resolution. We will provide further updates as more information becomes available from our partner side.
Posted Sep 03, 2026 - 08:11 PDT
Investigating
On Thursday, Sept 3, 2026, Marqeta identified an issue causing service degradation affecting MasterCard integration services, which may result in increased latency or timeout errors for token lifecycle management requests and Click To Pay enrolment. Impact began at approximately 06:27 PDT, and our engineering team is actively monitoring the situation while raising an incident directly with MasterCard to identify and resolve the underlying infrastructure issues impacting these endpoints. We are prioritizing this investigation to restore full service performance and will provide further updates as more information becomes available.
Posted Sep 03, 2026 - 07:33 PDT
This incident affected: Card Issuing, Card Fulfillment, Digital Wallets & Tokenization, and Risk & Disputes.