We have successfully processed the final batch of clearing files. Following a thorough reconciliation against the Visa network summary, we can confirm that all expected clearing data is aligned and validated.
Posted May 15, 2026 - 20:46 PDT
Update
Our teams have been actively monitoring file receipt and processing throughout the day, and we have confirmed that overall clearing volume today exceeds our previous day's totals, with most recent file processed at 14:35 PDT, We are also working to formally reconcile received data against the Visa network summary to provide full confirmation that all expected clearing activity has been recovered, and will provide a further update once reconciliation is complete. We sincerely apologize for any disruption this delay may have caused.
Posted May 15, 2026 - 16:58 PDT
Identified
Our technical teams have confirmed after engaging Visa that we have processed from our side all files sent so far from Visa. Marqeta is currently addressing a potential delay in the delivery of clearing files from the Visa network., While these files are now being ingested and prioritized through our systems to restore full data visibility, customers may experience temporary discrepancies in data reporting or reconciliation against VSS reports for the impacted date. We are closely monitoring the processing of files sent from Visa side to ensure all records are accurately reflected, We will provide a further update as soon as the processing is complete and data integrity is fully verified.
Posted May 15, 2026 - 10:16 PDT
Investigating
We receive 6 large files from Visa each day containing clearing for Marqeta customers. The last clearing file from the 14th of May has not yet been received from Visa.
Impacted customers will have a lower number than normal of clearing webhooks and VSS reports particular to this file are delayed.
We have reached out to Visa to understand what has happened, and to ensure the file is sent.
Once the file has been received by Marqeta, it will be immediately processed and we will update this incident.
Posted May 15, 2026 - 02:12 PDT
This incident affected: Reporting & Analytics and Webhooks.