Real Time Decisioning service is impaired

Incident Report for Marqeta

Resolved

Engineers report that functionality is restored and most data should be caught back up.
Posted Jun 06, 2025 - 07:18 PDT

Update

We are continuing to monitor the progress of the fix. All functionality should be restored and data caught up in about 3 hours.
Posted Jun 06, 2025 - 04:52 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 18:48 PDT

Update

Engineers are still engaged and are continuing to work to completely and safely restore the remainder of RTD services.
Posted Jun 05, 2025 - 12:01 PDT

Update

Engineers are still engaged and are continuing to work to completely and safely restore the remainder of services.
Posted Jun 05, 2025 - 11:00 PDT

Update

Engineers are engaged and continuing to work to completely restore the remainder of services.
Posted Jun 05, 2025 - 10:02 PDT

Update

Engineers are engaged and continuing to work to completely restore the remainder of services.
Posted Jun 05, 2025 - 08:35 PDT

Update

Engineers are engaged and continuing to work to completely restore the remainder of services.
Posted Jun 05, 2025 - 07:33 PDT

Update

Engineers are engaged and continuing to work to completely restore the remainder of services.
Posted Jun 05, 2025 - 06:30 PDT

Identified

Marqeta Engineers have identified the root cause and synchronous flow for RTD premium customers is restored. The team is engaged and working through restoration for the remainder of services.
Posted Jun 05, 2025 - 05:27 PDT

Investigating

Marqeta Engineers were alerted to failed requests to our RTD service. A team is engaged and actively investigating the root cause of these alerts.
Posted Jun 05, 2025 - 04:14 PDT
This incident affected: Risk & Disputes.