Delay in Receiving Visa Clearing Files

Incident Report for Marqeta

Resolved

All delayed files have been processed.
Posted Jun 29, 2026 - 11:21 PDT

Update

On Monday, June 29, 2026, Marqeta engineers detected a delay in receiving Visa clearing files, starting at approximately 05:45 PT (12:45 UTC). Visa has addressed an internal issue and has successfully sent the files. This will result in a ~3 hour delay for clearing processing and reporting. We will update this space again once the delay has been addressed, or upon any notable change in status.
Posted Jun 29, 2026 - 06:53 PDT

Investigating

On Monday, June 29, 2026, Marqeta engineers detected a delay in receiving Visa clearing files, starting at approximately 05:45 PT (12:45 UTC). Our team is engaging Visa to actively investigate the root cause and provide the files in a timely manner.

A follow-up notification with more detail will be sent when we receive context from Visa.
Posted Jun 29, 2026 - 06:12 PDT
This incident affected: Payment Processing.