Clearings on Visa and Mastercard Delayed, 16 December

Incident Report for Marqeta

Resolved

As of 4:40 PM PT, engineers confirmed that all files have completed processing. Clearing webhooks and reporting should be functioning as expected.
Posted Dec 18, 2025 - 16:51 PST

Update

For Mastercard, program level split files are continuing to progress with no ETA yet. Clearing webhooks have an ETA of one hour. Engineers are investigating reports of missing Mastercard T112 reports, and will look to resend them by end of day.

While we don't have an exact ETA for complete resolution at this time, we will continue to provide additional details as they become available.
Posted Dec 18, 2025 - 08:57 PST

Update

Visa files have finished processing. Engineers have completed the program level split files and they are now currently processing; we will continue to monitor their progress.

While we don't have an exact ETA for complete resolution at this time, we will provide additional details as they become available.

The next update will occur when all files have been fully processed and we can confirm operational status.
Posted Dec 17, 2025 - 17:36 PST

Update

Engineers have clarified that Mastercard files were also impacted in the same timeframe. We are continuing to monitor the processing of Visa and Mastercard clearing files.

Currently, the engineers have re-created the program level split files for clearing and reporting. As a part of this work there is a focus on preventing duplicate files from being sent. Once complete, we will send the split files to be cleared and/or delivered to customers.

The next update will occur when we have confirmed that all files are caught up.
Posted Dec 17, 2025 - 08:20 PST

Update

Engineers found the root cause, and have mitigated. The files are now being processed, Marqeta customers will start to see clearing webhooks now.

We will monitor the procesing of clearing files, and update this incident when we are caught up, and will note that we are Operational then.
Posted Dec 16, 2025 - 03:17 PST

Investigating

We are investigating issues processing Visa clearing and settlement files for today. We see no issues with clearings and settlement files for other networks. We see no impact to authorizations from any Network.

Since the files have not been processed, impacted Marqeta customers on Visa will see an absence of clearing webhooks, and no Visa VSS report files until this incident is resolved. Prrefunded customers will see no clearings posted to cardholder balances until this incident is mitigated.
Posted Dec 16, 2025 - 02:51 PST
This incident affected: Payment Processing and Reporting & Analytics.